Home Home > 2011 > 06 > 17 > ATI/AMD fglrx 8.861 Catalyst 11.6 available for openSUSE 11.2, 11.3, 11.4, Factory
Sign up | Login

ATI/AMD fglrx 8.861 Catalyst 11.6 available for openSUSE 11.2, 11.3, 11.4, Factory

June 17th, 2011 by

New version of catalyst 11.6 / fglrx 8.861 available

fglrx-8.861

Please refer to my previous article where all the installation procedure is explained.

  • Quick résumé :
  • There’s no full changelog about them, but Catalyst 11.6 installer (pdf)
  • Get the cheat-sheet 11.6 version
  • Kernel supported up to 3.0x version
  • Should be the latest version supporting 11.2
  • Wrong (to my point of view) create an xorg.conf file which is unneeded if you work with /etc/xorg.conf.d/50-device.conf and have driver "fglrx&quot inside

Warning

Some instabilities could happen. In case of crash like no keyboard, mouse, and blackscreen on reboot. Try to shutdown properly your computer with the shutdown poweroff button (or remote ssh). On reboot, just add 3 at the end of grub line to restart in console mode.
Then with yast or zypper you can always remove the actual version and try the previous version available in the repos.

All credits to Sebastian Siebert (freespacer) : 11.6 article (German)

What about tumbleweed, factory?

Users have reported that version 8.861 of catalyst 11.6 compile correctly under Tumbleweed with 2.6.39 kernel and the driver is ready for kernel 3.0x, so until xorg change too much and then AMD support for the new version, installing the 11.4 version should work

For factory, I’ve build a repository (see previous article) that can be used, and fglrx build.
The new package are called SUSE121 & no more SUSEFACTORY.

Stats Numbers ?

Month Unique IP Number of visits Pages Hits Bandwidth
Jan 2011 2355 6411 19688 35263 16.63 GB
Feb 2011 2906 7719 26383 41142 22.37 GB
Mar 2011 8055 21157 228494 258613 59.13 GB
Apr 2011 10592 29129 418281 437416 76.87 GB
May 2011 12511 36816 608350 626901 104.91 GB

All proudly served by openSUSE powered server! zypper dup from 11.2 to 11.4 in 45minutes last month

Both comments and pings are currently closed.

10 Responses to “ATI/AMD fglrx 8.861 Catalyst 11.6 available for openSUSE 11.2, 11.3, 11.4, Factory”

  1. Hi Bruno. I’m refreshing the repo but i can only see version 8.850-1 not 8.861.

    Thanks.

  2. I have also tried to remove the repo and add it again with no effect. Versions up to 8.850-1 are displayed only. Although when i browse the repo (with Firefox) 8.861 is there. It seems that something is wrong with the repond.xml file.

  3. Yes i told before browsing the repo shows that the new driver exists.

    zypper ref -f ATI responds with

    Signature verification failed for file ‘repomd.xml’ from repository ‘ATI’.
    Warning: This might be caused by a malicious change in the file!
    Continuing might be risky. Continue anyway? [yes/no] (no): yes
    Retrieving repository ‘ATI’ metadata [done]
    Forcing building of repository cache
    Building repository ‘ATI’ cache [done]
    Specified repositories have been refreshed.

    zypper se -s fglrx fails to report the new version.

    Loading repository data…
    Reading installed packages…

    S | Name | Type | Version | Arch | Repository
    –+———————-+———+———–+——–+———–
    i | fglrx64_xpic_SUSE114 | package | 8.850-1 | x86_64 | ATI
    v | fglrx64_xpic_SUSE114 | package | 8.831.2-1 | x86_64 | ATI
    v | fglrx64_xpic_SUSE114 | package | 8.821-1 | x86_64 | ATI
    | fglrx_xpic_SUSE114 | package | 8.850-1 | i586 | ATI
    | fglrx_xpic_SUSE114 | package | 8.831.2-1 | i586 | ATI
    | fglrx_xpic_SUSE114 | package | 8.821-1 | i586 | ATI

  4. Bruno i found it. Something is wrong when i’m accessing the PMS through proxy. I have a proxy in my setup (on opensuse server). Any other repository that i have works through the proxy without issues but yours seems not to going well with this setup.

    It is strange because i’m refreshing all the repos (and i have a lot) through the proxy without issues but not yours. Also the i’m using your repo for some time now and i hadn’t this problem. It seems that the problem appeared only after the last repository change.

    • Stratos Thanks for the report.
      I will regenerate signature this afternoon, just to be sure.
      Don’t know if this is due to the link of the repository, or eventually some gzipped output made by the server.
      I will investigate that a bit more.

      • I’ve refreshed all repodata + renew all signatures.
        Please try again, and just note the time you do your refresh ( I will be able to dig logs files for that time ).

        I’ve try the download behind a proxy too here, and it’s seems to work.
        Please report any success or failure, if you know your ip, tell me.
        Sometimes the anti-bot/script-kiddy protection can blacklist an ip.

  5. Anonymous

    Any word yet on GNOME 3 compatibility?

  6. Sarynn

    There is a changelog here…
    http://support.amd.com/us/kbarticles/Pages/AMDCatalyst116ReleaseNotes.aspx