Home Home > 2013 > 01 > 24 > ATI/AMD catalyst fglrx legacy updated to new 13.1 version
Sign up | Login

ATI/AMD catalyst fglrx legacy updated to new 13.1 version

January 24th, 2013 by

Proprietary AMD/ATI Catalyst fglrx legacy 13.1 (8.97.100.7-1) rpm released

Notice

This release concern only radeon HD2xxx to HD4xxx owners

The published Catalyst fglrx rpm version support openSUSE version from 11.4 to 12.3 (new repository) and also Tumbleweed (thus also kernel 3.8x series).
For testing with the next openSUSE 12.3 just use the new openSUSE_12.3 repo

The release note

Feedback

Sebastian Siebert will publish an article today, and he’s looking for feedback about the patches included to make it working on 12.3, so don’t hesitate to get in touch with him

Comments:

As I didn’t have a gpu card of this series, I can’t test it before publishing the rpm like for normal fglrx. If someone has a spare hd2xxx or hd4xxx, Could he(she) contact me?

Have fun!

Both comments and pings are currently closed.

7 Responses to “ATI/AMD catalyst fglrx legacy updated to new 13.1 version”

  1. Carlos A.

    Greetings.
    Have an HD4xxx, don’t remember the exact model, available in my laptop.
    Had no success installing the legacy driver since I installed openSuSE 12.2.
    Hope I get some luck now.
    Will the drivers be available through the repositories or are they available through the popular update scripts?

    Thanks for the help.

  2. Carlos A.

    Makerpm needs to change as it only looks and uses the past version of Ati legacy drivers.
    atiupgrade works, detects a new version, but could download it as it couldn’t find it.

  3. Carlos A.

    Greetings, have to correct the last posts. The legacy script will be shared soon. The current script works with not legacy GPU.

  4. Marek Paśnikowski

    I tried my best to install the driver on OpenSUSE 12.3 but it kept failing to work with X. The crash log is consistently same:
    [code]
    [ 106.684]
    X.Org X Server 1.13.1
    Release Date: 2012-12-13
    [ 106.684] X Protocol Version 11, Revision 0
    [ 106.684] Build Operating System: openSUSE SUSE LINUX
    [ 106.684] Current Operating System: Linux hirager-5.home 3.4.6-2.10-desktop #1 SMP PREEMPT Thu Jul 26 09:36:26 UTC 2012 (641c197) x86_64
    [ 106.684] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.4.6-2.10-desktop root=UUID=9cbf4b06-789f-4ef3-ae5c-05062564a75b resume=/dev/disk/by-id/ata-ST3500418AS_9VM1E297-part1 splash=silent quiet showopts
    [ 106.684] Build Date: 10 January 2013 09:13:13PM
    [ 106.684]
    [ 106.684] Current version of pixman: 0.28.2
    [ 106.684] Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    [ 106.684] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 106.684] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 25 15:35:40 2013
    [ 106.684] (==) Using config file: "/etc/X11/xorg.conf"
    [ 106.684] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [ 106.684] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [ 106.684] (==) ServerLayout "aticonfig Layout"
    [ 106.684] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
    [ 106.684] (**) | |-->Monitor "aticonfig-Monitor[0]-0"
    [ 106.685] (**) | |-->Device "aticonfig-Device[0]-0"
    [ 106.685] (==) Automatically adding devices
    [ 106.685] (==) Automatically enabling devices
    [ 106.685] (==) Automatically adding GPU devices
    [ 106.685] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    [ 106.685] Entry deleted from font path.
    [ 106.685] (==) FontPath set to:
    /usr/share/fonts/misc:unscaled,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/ghostscript/,
    /usr/share/fonts/cyrillic:unscaled,
    /usr/share/fonts/truetype/,
    built-ins
    [ 106.685] (==) ModulePath set to "/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"
    [ 106.685] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
    [ 106.685] (II) Loader magic: 0x801c20
    [ 106.685] (II) Module ABI versions:
    [ 106.685] X.Org ANSI C Emulation: 0.4
    [ 106.685] X.Org Video Driver: 13.1
    [ 106.685] X.Org XInput driver : 18.0
    [ 106.685] X.Org Server Extension : 7.0
    [ 106.686] (--) PCI:*(0:1:0:0) 1002:9460:174b:e115 rev 0, Mem @ 0xd0000000/268435456, 0xfeaf0000/65536, I/O @ 0x0000c000/256, BIOS @ 0x????????/131072
    [ 106.686] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    [ 106.686] Initializing built-in extension Generic Event Extension
    [ 106.686] Initializing built-in extension SHAPE
    [ 106.686] Initializing built-in extension MIT-SHM
    [ 106.686] Initializing built-in extension XInputExtension
    [ 106.686] Initializing built-in extension XTEST
    [ 106.686] Initializing built-in extension BIG-REQUESTS
    [ 106.686] Initializing built-in extension SYNC
    [ 106.686] Initializing built-in extension XKEYBOARD
    [ 106.686] Initializing built-in extension XC-MISC
    [ 106.686] Initializing built-in extension SECURITY
    [ 106.686] Initializing built-in extension XINERAMA
    [ 106.686] Initializing built-in extension XFIXES
    [ 106.686] Initializing built-in extension RENDER
    [ 106.686] Initializing built-in extension RANDR
    [ 106.686] Initializing built-in extension COMPOSITE
    [ 106.686] Initializing built-in extension DAMAGE
    [ 106.686] Initializing built-in extension MIT-SCREEN-SAVER
    [ 106.686] Initializing built-in extension DOUBLE-BUFFER
    [ 106.686] Initializing built-in extension RECORD
    [ 106.686] Initializing built-in extension DPMS
    [ 106.686] Initializing built-in extension X-Resource
    [ 106.686] Initializing built-in extension XVideo
    [ 106.686] Initializing built-in extension XVideo-MotionCompensation
    [ 106.686] Initializing built-in extension XFree86-VidModeExtension
    [ 106.686] Initializing built-in extension XFree86-DGA
    [ 106.686] Initializing built-in extension XFree86-DRI
    [ 106.686] Initializing built-in extension DRI2
    [ 106.686] (II) "glx" will be loaded by default.
    [ 106.686] (II) LoadModule: "glx"
    [ 106.686] (II) Loading /usr/lib64/xorg/modules/updates/extensions/libglx.so
    [ 106.686] (II) Module glx: vendor="Advanced Micro Devices, Inc."
    [ 106.686] compiled for 6.9.0, module version = 1.0.0
    [ 106.687] Loading extension GLX
    [ 106.687] (II) LoadModule: "fglrx"
    [ 106.687] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
    [ 106.700] (EE) Failed to load /usr/lib64/xorg/modules/drivers/fglrx_drv.so: /usr/lib64/xorg/modules/drivers/fglrx_drv.so: undefined symbol: noXFree86DRIExtension
    [ 106.700] (II) UnloadModule: "fglrx"
    [ 106.700] (II) Unloading fglrx
    [ 106.700] (EE) Failed to load module "fglrx" (loader failed, 7)
    [ 106.700] (EE) No drivers available.
    [ 106.700]
    Fatal server error:
    [ 106.700] no screens found
    [ 106.700] (EE)
    Please consult the The X.Org Foundation support
    at http://wiki.x.org
    for help.
    [ 106.700] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [ 106.700] (EE)
    [/code]

    • Known bug, unfortunately the new xorg 1.13 made a hard life to the old fglrx-legacy code …
      Please post report to the sebastian blog. As described in previous article or in the wiki by using his makerpm script to grab all the usefull information