Home Home > 2009 > 12 > 08 > Install Multiple Kernel Versions using the YaST Qt Package Manager
Sign up | Login

Install Multiple Kernel Versions using the YaST Qt Package Manager

December 8th, 2009 by

You might want to install multiple kernel versions on your system.
The YaST Qt Package Selector provides a nice user interface that allows to manage multiple package versions now.

yast2-qt-pkg 2.18.19 or later supports this feature. You can find packages in my Build Service repository.

First of all you need to tell libzypp that your kernel is a package which is multiversion-enabled by adding this line to your /etc/zypp/zypp.conf:

multiversion = provides:multiversion(kernel)

Start your YaST Software Management. The versions tab shows check boxes for multiversion packages instead of radio buttons.
This enables you to install multiple versions of the same package.

There is also a package group of multiversion packages that list all packages that can be installed in multiple versions.

YaST Qt Package Manager with Multiversion Kernel Packages

Both comments and pings are currently closed.

7 Responses to “Install Multiple Kernel Versions using the YaST Qt Package Manager”

  1. remur

    Yey, any time frame when this will hit a more official repository?
    And manually editing /etc/zypp/zypp.conf is just a temporary solution I take it? Couldn’t this be determined through the database?

    • Thomas Göttlicher

      It’s submitted to YaST:Head. As soon as libzypp 6.26.3 is available YaST:Head will contain the latest version.
      Libzypp figures out which packages are mutliversion packages by reading /etc/zypp/zypp.conf. As far as I know the database doesn’t know anything about multiversions.

  2. philip

    Is this the same as
    #zypper se -s kernel-desktop?

    • Thomas Göttlicher

      Well, ‘zypper se’ searches for packages while clicking the icons in the packages selector installs multiple versions. The shown list of versions in the UI is similar to the zypper search.

  3. Anonymous

    Please make it clearer, upfront that this is development and future stuff coming in next release, not a tip to enabling a hidden 11.2 feature. Wew users get confused by official looking blog items, and end up adding Factory repo’s and get themselves into messes.

    libzypp >= 6.26.3 is needed by yast2-qt-pkg-2.18.19-3.1.x86_64

    If you want ppl to try it and test it against 11.2, then ALL the package upgrades need to be together in a repo.

    • Thomas Göttlicher

      You are right this isn’t a hidden feature in openSUSE 11.2 but the next release will contain it. If you want to use it now you need yast2-qt-pkg 2.18.19 and libzypp 6.26.3.

    • HuHa

      Uh — this would be confusing to exactly whom? To a newbie who just installed openSUSE for the very first time — but one who reads developers’ blogs? Get real.

      And, no offense, if you are that clueless, better not mess with something as central to your system as the software management stack. Better be glad that missing dependency saved you from wrecking your system.