Home Home > 2008 > 10 > 09 > OpenOffice_org 3.0rc4 available
Sign up | Login

OpenOffice_org 3.0rc4 available

October 9th, 2008 by

I’m happy to announce that OpenOffice.org 3.0.0.3.4 rc4 packages are available in the Build Service OpenOffice:org:UNSTABLE project.

We hope that this is the last release candidate and that we will provide the final package in the OpenOffice:org:STABLE project the following week.

Even though, we are very close the final release, the package still might include even serious bugs. Therefore it is not intended for data-critical usage. A good practice is to archive any important data before an use, …

We kindly ask any interested beta testers to try the package and report bugs.

Note: openSUSE-11.1-beta2 and FACTORY include totaly reworked packages where the build is split into many source packages. It is a bit broken right now. We would like to put it into the Build Service as soon as possible but it will take some time to fix the build on older distributions again. Please be patient.

Where to Get It

The packages are provided by the OpenOffice:org:UNSTABLE installation repository.

Installation Problems

There are some problems with the version update on older distributions. You might need to select the right version by hand.

IMPORTANT

The packages with localizations are renamed from OpenOffice_org-<lang> to OpenOffice_org-l10n-<lang>. Also the localized help content is split into the optional OpenOffice_org-help-<lang> packages. Finally, the American localization is split into extra packages OpenOffice_org-l10n-en-US and OpenOffice_org-help-en-US.

We are sorry, the 64-bit packages are not available for SLED10 and openSUSE-10.2. You could install the 32-bit (i586) instead. We hope to solve the build problems within the following weeks.

Bug Reports

Please report the bugs into the Novell bugzilla for the product OpenOffice_org 2.0. Do not forget to mention enough information about the problem.

Changes in This Version

The detailed summary of the GO-OO project changes are in the NEWS document.

General Information About the Build

The build is based on the GO-OO project. It includes lots bug fixes, features
and optimizations in compare with the regular OpenOffice.org build:

  • better startup performance
  • improved VBA interoperability
  • improved import filters (OOXML, WordPerfect)
  • additional import filters (SVG, WordPerfect Graphics, Microsoft Works, …)
  • native KDE Open/Save dialog
  • WebDAV locking
  • new 3D slide transitions
  • multimedia in Impress via GStreamer
  • multiple formula syntax (Calc A1, Excel A1 and Excel R1C1)

, see also the discover page.

Both comments and pings are currently closed.

5 Responses to “OpenOffice_org 3.0rc4 available”

  1. Jordi Relats

    I hav download from http://download.opensuse.org/repositories/OpenOffice.org:/UNSTABLE/openSUSE_11.0/ and I’m using and is working well for me, I only have a problem and it is when I try to install the pdfimport extension I have the following mesage ” loading component library failed: file:///home/jordi_relats/.ooo3/user/uno_packages/cache/uno_packages/eNBb6r_/pdfimport.uno.so ”

    Whit earliers betas dowlodad from openoffice it works fine.

    Regards

    Jordi

  2. paulatz

    After a bit of digging I could solve the problem reported by Jordi.

    Short version: you have to install OpenOffice_org-devel (670MB!) and the RPM containing libstlport_gcc.so, I coudn’t find the latter in the opensuse packages, so I’ve taken it directly from sourceforge:

    rpm -ivh ftp://ftp.pbone.net/mirror/ftp.sourceforge.net/pub/sourceforge/w/wi/witme/STLport-4.5.3-9064.i386.rpm

    Longer version: if you unzip the extension file (do it in a new directory, as it will create a mess of files in the current directory) you can run

    ldd pdfimport.uno.so

    If you are experiencing the problem it will have a lot of undefined references, which prevent the library from loading. Track back the packages that includes the said libraries and it will work. Note that OpenOffice_org-devel does not put the library inside the library path, the path itself is extended is done somewhere inside the soffice wrapper. It means that even if you have all the libraries installed, running ldd will still show some missing ones; if you want to be sure you can redefine the LD_LIBRARY_PATH in order for ldd to find them:

    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/ooo3/devel/solver/300/unxlngi6.pro/lib/

    but remember to reset it to the previous value afterwards, otherwise OOo won’t work (crazy)!

  3. jake

    When come out the final OO 3.0.0 to OpenSuse (11.0)?
    OO 3.0.0.3.5 – x is yes nearly (rc5) but not real ready/final…

  4. stoyan gadjulov

    sure. pdfimport wroks well in home on my 64-bit opensuse but in office I use 32-bit opensuse and got the memntioned error. so I digged the web for solution. The a.m. comment helped me to solve the problem. The most easy way for me is to
    1. download pdfimport.oxt
    2. copy to /usr/lib/ooo3/ure/lib (I have unzipped oxt and checked with “ldd pdfimport.uno.so and”, then I found that missing files are installed with ooo3 into “/usr/lib/ooo3/ure/lib” folder) – you’ll need root access
    3. intall the extention as ordinary user from “/usr/lib/ooo3/ure/lib”
    That is all folk

  5. Ivelin Ivanov

    I am looking for repository to upgrade to OpenOffice 3.0 on OpenSuSE 10.2. Does anyone knows where I can find one ?
    Thanks in advance!